FL-1851p- Apopka FL- Peak Circle
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Jan 18, 2025 - 13:09 CST
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 2pm.
Posted Jan 18, 2025 - 10:53 CST