Chicago, IL - 60 E. Monroe St.
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 01:03 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 12:10am.
Posted Sep 17, 2024 - 23:20 CDT
This incident affected: Zentro Network (Zentro Internet).