MI-71G - Detroit, MI - 71 Garfield St

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Mar 02, 2025 - 16:13 CST

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue.
Posted Mar 02, 2025 - 13:12 CST