Santa Monica, CA - 2720 Neilson Way

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Nov 19, 2025 - 08:43 CST

Identified

We are continuing to investigate the issue as our technicians work to restore service. We apologize for the inconvenience. The next update will be provided by 10:00 A.M. PST.
Posted Nov 19, 2025 - 00:56 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Nov 18, 2025 - 17:55 CST
This incident affected: Zentro Network (Zentro Internet).