Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 21, 2024 - 11:16 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Sep 20, 2024 - 09:10 CDT
This incident affected: Zentro Network (Zentro Internet).