Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 03, 2025 - 14:59 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is by mid-day 4/2/25.
Posted Apr 01, 2025 - 16:49 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is by end of day 4/1/25.
Posted Mar 31, 2025 - 14:56 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. At this time we have identified the issue and are currently coordinating with our network team to implement a solution. At this time we do not have a clear ETR but we will be updating information as we receive it from our team onsite.
Posted Mar 29, 2025 - 15:53 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue.
Posted Mar 29, 2025 - 10:02 CDT
Investigating
We are investigating reports of service interruptions at the location.