11136 Chandler Blvd, Los Angeles, CA

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Jan 24, 2026 - 11:42 CST

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 7:00 PM PST.
Posted Jan 23, 2026 - 17:39 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Jan 23, 2026 - 12:29 CST
This incident affected: Zentro Network (Zentro Internet).