10100 Galaxy Way, Los Angeles, CA

Incident Report for Zentro

Identified

We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time of repair at this time.
Posted Nov 21, 2025 - 13:42 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Nov 21, 2025 - 11:38 CST
This incident affects: Zentro Network (Zentro Internet).