Florida Severe Weather
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 11, 2024 - 12:08 CDT
Monitoring
Valued Customers in the Florida Area,

We understand that Hurricane Milton is causing significant challenges, including intermittent power and internet service disruptions in some areas. Our thoughts are with you during this difficult time. We are committed to providing you with the support you need and are working diligently to restore service as quickly as possible.

For the most up-to-date information on service status and assistance, please check this website periodically.

Thank you for your patience and understanding.
Posted Oct 09, 2024 - 15:32 CDT
This incident affected: Zentro Network (Zentro Internet).