Chicago, IL - 3700 W. Congress Pkwy.
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 22, 2024 - 17:11 CDT
Update
We are still working on this site, weather related events are continuing to impact connectivity. Estimated time of repair 7:00 P.M
Posted Sep 22, 2024 - 14:16 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 22, 2024 - 14:16 CDT
Identified
We are still working on this site, weather related events are continuing to impact connectivity. Estimated time of repair 7:00 P.M
Posted Sep 22, 2024 - 11:20 CDT
Investigating
We are investigating reports of service interruptions at the location due to weather related events.
Posted Sep 22, 2024 - 09:48 CDT
This incident affected: Zentro Network (Zentro Internet).