Chicago, IL- 6044 N. Winthrop Ave

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Feb 28, 2025 - 18:08 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 28, 2025 - 10:05 CST