Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 31, 2025 - 04:10 CST
Update
We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time for resolution.
Posted Dec 30, 2025 - 13:53 CST
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 12:00 PM EST.
Posted Dec 30, 2025 - 08:46 CST
Update
We have been notified of a power outage in your area. We are awaiting an update from Local Power Utility for an estimated time for resolution. Next update will be provided by 9 A.M. EST.
Posted Dec 30, 2025 - 00:48 CST
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 2:00 A.M. EST.
Posted Dec 29, 2025 - 20:37 CST
This incident affected: Zentro Network (Zentro Internet).