450T - Lincolnwood, IL - 7215 District Ave/450 Touhy

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Mar 15, 2025 - 16:44 CDT

Investigating

We are investigating reports of local power issues impacting service.
Posted Mar 15, 2025 - 13:49 CDT