Residents of Cleveland properties

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 09:25 CST

Update

Some select Cleveland properties may be experiencing connectivity issues. Our Team is currently investigating.
Posted Mar 03, 2025 - 13:46 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Mar 03, 2025 - 12:57 CST
This incident affected: Zentro Network (Zentro Internet).