300 Riverfront Dr, Detroit MI

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 21, 2025 - 07:30 CDT

Update

Customers may be experiencing service interruptions. Our team is working alongside our fiber partners to locate and repair damaged fiber components. The primary damage has been repaired but a secondary fiber cut was discovered. Splicing efforts are still ongoing, due to the complexity of the incident, our next status update will be provided by 12:00 PM EST on 10/21. We apologize for the inconvenience and appreciate your patience and understanding in the matter. To stay informed with the latest news, please click 'Subscribe.'
Posted Oct 20, 2025 - 18:21 CDT

Identified

Customers may be experiencing service interruptions. Our team is working alongside our fiber partners to locate and repair damaged fiber components. Splicing efforts are still ongoing, due to the complexity of the incident, our next status update will be provided by 12:00 PM EST on 10/21. We apologize for the inconvenience and appreciate your patience and understanding in the matter. To stay informed with the latest news, please click 'Subscribe.'
Posted Oct 20, 2025 - 11:02 CDT

Update

Customers may be experiencing service interruptions. Our team is working alongside our fiber partners to locate and repair damaged fiber components. Splicing efforts are still ongoing, due to the complexity of the incident our next status update will be provided by 12:00 PM EST on 10/20. We apologize for the inconvenience and appreciate your patience and understanding in the matter. To stay informed with the latest news, please click 'Subscribe.'
Posted Oct 18, 2025 - 13:39 CDT

Update

Customers may be experiencing service interruptions. Our team is working alongside our fiber partners to locate and repair damaged fiber components. At this time, we do not have an estimated time of repair but our next update will be provided by 12:00 PM EST on 10/18/25. We apologize for the inconvenience and appreciate your patience and understanding in the matter. To stay informed with the latest news, please click 'Subscribe.'
Posted Oct 17, 2025 - 20:29 CDT

Update

We are continuing to investigate this issue.
Posted Oct 17, 2025 - 08:56 CDT

Investigating

We are currently investigating this issue.
Posted Oct 17, 2025 - 08:55 CDT
This incident affected: Zentro Network (Zentro Internet).