5652 La Mirada Ave., Los Angeles, CA

Incident Report for Zentro

Resolved

Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Nov 18, 2025 - 13:45 CST

Identified

The incident has been isolated to local electrical issues impacting our networking equipment. Our team is coordinating repair efforts with property management. To stay informed with the latest updates, please click 'Subscribe'.
Posted Nov 14, 2025 - 14:52 CST
This incident affected: Zentro Network (Zentro Internet).