4447 N. Kedzie Ave., 4815 N. Christiana Ave., 3101 W. Leland Ave., 3102 W. Sunnyside Ave., 3119 W. Lawrence Ave. - Chicago IL

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted May 28, 2025 - 14:02 CDT

Investigating

We are investigating reports of local power issues impacting service.
Posted May 28, 2025 - 11:01 CDT
This incident affected: Zentro Network (Zentro Internet).