240 20th Street, Atlanta, GA
Incident Report for Zentro Internet
Resolved
Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 16, 2024 - 19:50 CDT
Update
Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 16, 2024 - 19:47 CDT
Monitoring
Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 16, 2024 - 14:20 CDT
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 1PM EST.
Posted Sep 16, 2024 - 10:37 CDT
This incident affected: Zentro Network (Zentro Internet).