169 West Huron Street - Chicago, IL

Incident Report for Zentro

Resolved

Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 02, 2025 - 04:47 CST

Identified

Customers may be experiencing intermittent connectivity due to local power issues affecting our equipment. Local Power Utility has provided an estimated time to resolution by 2 AM CST.
Posted Dec 01, 2025 - 21:52 CST
This incident affected: Zentro Network (Zentro Internet).