Gainesville, GA - 1701 Dawsonville Hwy

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 08:01 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has not provided an updated time of resolution at this time.
Posted Mar 21, 2025 - 20:03 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 9:00 PM EST
Posted Mar 21, 2025 - 19:47 CDT

Identified

We have been notified of a power outage in your area affecting our equipment. Local Power Utility has an estimated time for resolution by 8:45 EST.
Posted Mar 21, 2025 - 19:32 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Mar 21, 2025 - 18:53 CDT
This incident affected: Zentro Network (Zentro Internet).