Chicago, IL - 155 N. Harbor Dr.
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 16:49 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 6:01AM.
Posted Oct 07, 2024 - 02:05 CDT
This incident affected: Zentro Network (Zentro Internet).