2700 North Halsted Street, Chicago, IL
Incident Report for Zentro Internet
Resolved
Due to access difficulties, we are not able to do the necessary repairs to fix the issue. We are awaiting access to resolve the issue.
Posted Sep 05, 2024 - 14:09 CDT
Update
Due to access difficulties, we are not able to do the necessary repairs to fix the issue. We are awaiting access to resolve the issue.
Posted Sep 05, 2024 - 08:55 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue.
Posted Sep 04, 2024 - 18:28 CDT
This incident affected: Zentro Network (Zentro Internet).