325 W. Fullerton Pkwy. Chicago IL

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 07:15 CDT

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 6:00 PM.
Posted Apr 29, 2025 - 13:43 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Apr 29, 2025 - 12:24 CDT
This incident affected: Zentro Network (Zentro Internet).