Some customers may be experiencing intermittent connectivity at this time. Our service partners are actively troubleshooting the issue at the data center. We sincerely apologize for the inconvenience and appreciate your patience as we work to resolve the matter. At this time we are pending an estimated time of repair, the next status update will be shared by 10:00 PM EST. To stay informed with the latest updates, please click "Subscribe".
Posted Sep 18, 2025 - 16:02 CDT
Update
Customers may be experiencing intermittent connectivity. Our technicians have been dispatched and have identified the issue as a fiber cut caused by construction in the area. The majority of repairs have been completed, and we are continuing work to ensure all customer connections are restored. We will provide additional updates by 8PM Eastern.
Posted Sep 17, 2025 - 15:05 CDT
Update
Customers may be experiencing intermittent connectivity. Our technicians have been dispatched and have identified the issue as a fiber cut caused by construction in the area. The majority of repairs have been completed, and we are continuing work to ensure all customer connections are restored. We will provide additional updates by 12 PM Eastern.
Posted Sep 17, 2025 - 07:40 CDT
Update
Customers may be experiencing intermittent connectivity. Our technicians have been dispatched and have identified the issue as a fiber cut caused by construction in the area. Some repairs have been completed, and we are working to ensure all customer connections are restored. We will provide additional updates by 12 PM Eastern.
Posted Sep 16, 2025 - 09:36 CDT
Identified
Customers may be experiencing intermittent connectivity. Our technicians have been dispatched and have identified the issue as a fiber cut caused by construction in the area. We have engaged our service partners to repair the cut and will provide additional updates by 8PM Eastern.
Posted Sep 15, 2025 - 16:06 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Sep 15, 2025 - 09:46 CDT
This incident affects: Zentro Network (Zentro Internet).