544 West Oak Street, Chicago, IL

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 09:10 CST

Update

Customers may be experiencing intermittent connectivity. Our team is coordinating repairs with building staff, our next update will be 12/30/25 @ 12:00 PM CST. To stay informed, please click 'Subscribe'.
Posted Dec 29, 2025 - 17:45 CST

Update

Customers may be experiencing intermittent connectivity. Our team is coordinating repairs with building staff, the estimated repair time is 12/29 @ 3:00 PM CST. To stay informed, please click 'Subscribe'.
Posted Dec 26, 2025 - 18:34 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 26, 2025 - 10:47 CST
This incident affected: Zentro Network (Zentro Internet).