Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 12, 2025 - 15:24 CDT
Monitoring
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 12, 2025 - 12:21 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 12:00 PM CST.
Posted Apr 12, 2025 - 10:46 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Apr 12, 2025 - 10:09 CDT
This incident affected: Zentro Network (Zentro Internet).