Nashville, TN - 1315 Adams St.
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 13, 2024 - 10:57 CST
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 3 AM
Posted Dec 12, 2024 - 22:27 CST
This incident affected: Zentro Network (Zentro Internet).