IL-464G - 464 Glenwood Avenue, Glen Ellyn, IL

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Nov 08, 2025 - 13:09 CST

Identified

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 5pm
Posted Nov 08, 2025 - 08:51 CST