Chicago, IL - 4119 South Ellis Avenue

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Aug 23, 2025 - 09:23 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time for resolution.
Posted Aug 17, 2025 - 16:29 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 4:00 PM Central.
Posted Aug 17, 2025 - 14:55 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 11:45 PM CST.
Posted Aug 15, 2025 - 18:02 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time for resolution.
Posted Aug 13, 2025 - 08:39 CDT

Update

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 11:45AM CDT.
Posted Aug 12, 2025 - 08:14 CDT

Identified

We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time for resolution yet.
Posted Aug 12, 2025 - 07:12 CDT
This incident affected: Zentro Network (Zentro Internet).