Chicago, IL - 4611 South Drexel Boulevard

Incident Report for Zentro

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is to be determined.
Posted Jan 25, 2026 - 16:50 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Jan 25, 2026 - 15:29 CST
This incident affects: Zentro Network (Zentro Internet).