Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jul 08, 2025 - 09:35 CDT
Update
We have been notified of a power outage in your area. Local Power Utility has not provided an estimated time for resolution.
Posted Jul 07, 2025 - 10:46 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is TBD.
Posted Jul 07, 2025 - 10:45 CDT
Update
We are continuing to investigate this issue.
Posted Jul 07, 2025 - 10:44 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Jul 07, 2025 - 10:43 CDT
This incident affected: Zentro Network (Zentro Internet).