FL-2750UH1 - Sands at Saint Lucie - Building 11

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 06, 2025 - 09:01 CDT

Update

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is by the end of day, 4/7/25.
Posted Apr 03, 2025 - 15:27 CDT

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue.
Posted Apr 03, 2025 - 14:59 CDT