Ohio
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 11, 2024 - 15:31 CST
Monitoring
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Dec 11, 2024 - 15:06 CST
Identified
We are diligently working to resolve this as quickly as possible. Estimated time of resolution is 5 PM EST. Please click "Subscribe" above to receive updates on anticipated resolution.
Posted Dec 11, 2024 - 12:37 CST
Investigating
We’re aware of continued service interruptions affecting properties in Ohio. Our team is currently investigating. Click "Subscribe" above to receive updates on anticipated resolution.
Posted Dec 11, 2024 - 12:09 CST
This incident affected: Zentro Network (Zentro Internet).