Sands at Saint Lucie

Incident Report for Zentro

Update

We are currently experiencing a service interruption at this site and understand the inconvenience this may cause. Our team is actively working with property staff to restore connectivity by repairing affected network components. The estimated time of resolution is 12:00 PM EST on July 14. We appreciate your patience and understanding as we resolve this matter as quickly as possible.

To receive real-time updates on the status of this outage, please click ‘Subscribe’.
Posted Jul 12, 2025 - 18:55 CDT

Update

We understand how disruptive service interruptions can be, and we sincerely apologize for any inconvenience this may be causing. Our team is working with urgency and care to pinpoint the issue and restore services as quickly as possible. We’ll share the next status update at 6:00 PM EST. To stay in the loop, please click 'Subscribe'.
Posted Jul 12, 2025 - 14:22 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Jul 12, 2025 - 10:06 CDT
This incident affects: Zentro Network (Zentro Internet).