We have isolated the issue and continue working with our service partners to complete the necessary repairs. We do not currently have an estimated time for repair. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue.
Posted Aug 29, 2025 - 14:44 CDT
Update
We have isolated the issue and continue working with our service partners to complete the necessary repairs. The next update will be provided by 12:00 P.M. EDT tomorrow, 8/27. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue.
Posted Aug 26, 2025 - 14:02 CDT
Update
We have isolated the issue and continue working with our service partners to complete the necessary repairs. The next update will be provided by 12:00 P.M. EDT tomorrow, 8/26. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue.
Posted Aug 25, 2025 - 22:40 CDT
Update
Customers may be experiencing intermittent connectivity. We have isolated the issue and are working with our service partners to complete the necessary repairs. We are trying to restore service ASAP but currently do not have an estimated time of repair.
Posted Aug 25, 2025 - 18:01 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is to be determined.
Posted Aug 24, 2025 - 07:52 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Aug 23, 2025 - 15:26 CDT
This incident affects: Zentro Network (Zentro Internet).