10510 Park Lane | 10555 Euclid Avenue - Cleveland, OH

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jan 02, 2026 - 11:08 CST

Update

Customers may be experiencing intermittent connectivity. Our team is coordinating repairs with building staff, our next update will be 1/2/2026 @ 12:00 PM EST. To stay informed, please click 'Subscribe'.
Posted Jan 01, 2026 - 14:07 CST

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 6:30 PM EST.
Posted Jan 01, 2026 - 13:30 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Dec 31, 2025 - 20:09 CST
This incident affected: Zentro Network (Zentro Internet).