Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 12, 2025 - 16:21 CDT
Update
Customers may continue to experience intermittent connectivity. Fiber splicing will be conducted on-site with dedicated contractors on 9/12. We apologize for the inconvenience caused by service disruptions. To stay up to date with the latest updates, please click 'Subscribe'.
Posted Sep 12, 2025 - 10:26 CDT
Update
Customers may continue to experience intermittent connectivity. Fiber splicing will be conducted on-site with dedicated contractors between 12:00AM-6:00 AM on 9/12. We apologize for the inconvenience caused by service disruptions. To stay up to date with the latest updates, please click 'Subscribe'.
Posted Sep 11, 2025 - 15:09 CDT
Update
Customers may continue to experience intermittent connectivity, our team is coordinating with contractors for an emergency maintenance to repair damaged fiber. We apologize for the inconvenience, our team is working diligently to repair components. To stay up to date with the latest updates, please click 'Subscribe'.
Posted Sep 11, 2025 - 14:34 CDT
Update
Customers may be experiencing intermittent connectivity. Technicians have been dispatched and have identified the cause of the issue. We are working with our service partners to complete the necessary repairs. We do not currently have an estimated time for repair. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue.
Posted Sep 11, 2025 - 13:08 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched and have identified the cause of the issue. We are working with our service partners to complete the necessary repairs. We do not currently have an estimated time for repair. We apologize for the inconvenience and appreciate your patience as we work diligently on the issue.
Posted Sep 07, 2025 - 09:48 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Sep 04, 2025 - 13:04 CDT
This incident affected: Zentro Network (Zentro Internet).