Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jun 20, 2025 - 15:11 CDT
Update
Customers in buildings 19 & 20 may continue to experience intermittent connectivity. Our technicians have provided an ETR of 5:00 PM EST 6/20 as components were impacted further than previously anticipated. We apologize for the inconvenience, for up to date news please click 'Subscribe' to stay in the loop with the latest updates!
Posted Jun 19, 2025 - 19:28 CDT
Update
Customers may be experiencing intermittent connectivity. Our team is working diligently to restore services, updated estimated time of repair is 5:00 PM EST on 6/19. We apologize for the inconvenience, for up to date news please click 'Subscribe' to stay in the loop with the latest updates!
Posted Jun 18, 2025 - 12:44 CDT
Update
Customers may be experiencing intermittent connectivity. Our team is working diligently to restore services, estimated time of repair is 12:00 PM EST on 6/18. We apologize for the inconvenience, for up to date news please click 'Subscribe' to stay in the loop with the latest updates!
Posted Jun 17, 2025 - 20:47 CDT
Identified
The issue has been identified, and a fix is being implemented. Customer from building 19 & 20 are currently impacted. ETR 5pm
Posted Jun 17, 2025 - 14:52 CDT
This incident affected: Zentro Network (Zentro Internet).