Chicago, IL - 175 E. Delaware Pl.
Incident Report for Zentro
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 10:31 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 7:42AM.
Posted Sep 26, 2024 - 06:03 CDT
This incident affected: Zentro Network (Zentro Internet).