[IMAPCTED LOCATIONS]

Incident Report for Zentro

Resolved

Power and Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 13, 2025 - 09:45 CDT

Identified

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 9/13/2025, 10:00 AM CDT-We Energies
Posted Sep 13, 2025 - 08:33 CDT