1733 1/2 West Adams Boulevard, Los Angeles, CA

Incident Report for Zentro

Update

Customers may be experiencing intermittent connectivity. Our team is coordinating with building staff to restore services as soon as possible. Our next updated will be provided by Monday @ 3:00 PM PST. To stay informed, please click 'Subscribe'.
Posted Jan 25, 2026 - 07:43 CST

Identified

Customers may be experiencing intermittent connectivity. Our team is coordinating with building staff to restore services as soon as possible. Our next updated will be provided by 3:00 PM PST. To stay informed, please click 'Subscribe'.
Posted Jan 23, 2026 - 17:35 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Jan 23, 2026 - 10:16 CST
This incident affects: Zentro Network (Zentro Internet).