1851 Peak Circle, Apopka, FL

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 24, 2025 - 16:50 CDT

Update

We are currently experiencing a partial outage affecting some customers. Our service partners have identified the failed component, the replacement part is anticipated to be delivered tomorrow morning. Our estimated time of repair is 5:00 PM EST on 10/24/2025.
We sincerely apologize for the inconvenience and appreciate your patience and understanding. To stay informed with the latest updates, please click 'Subscribe'.
Posted Oct 24, 2025 - 12:26 CDT

Update

We are currently experiencing a partial outage affecting some customers. Our service partners have identified the failed component, the replacement part is anticipated to be delivered tomorrow morning. Our estimated time of repair is 12:00 PM EST on 10/24/2025.
We sincerely apologize for the inconvenience and appreciate your patience and understanding. To stay informed with the latest updates, please click 'Subscribe'.
Posted Oct 23, 2025 - 12:39 CDT

Identified

We are currently experiencing a partial outage affecting some customers. Our service partners will be on-site tomorrow morning to continue troubleshooting. The next update will be provided by 1:00 PM EST on 10/23.
We sincerely apologize for the inconvenience and appreciate your patience and understanding. To stay informed with the latest updates, please click 'Subscribe'.
Posted Oct 22, 2025 - 19:23 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Oct 22, 2025 - 13:46 CDT
This incident affected: Zentro Network (Zentro Internet).