Apopka, FL - 1851 Peak Circle | Building 2

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jun 30, 2025 - 16:53 CDT

Update

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 4:00 PM local time.
Posted Jun 30, 2025 - 12:08 CDT

Update

Customers may be experiencing intermittent connectivity. Technicians are working diligently to restore services, next update to be provided at 12:00 PM EST on 6/29. We sincerely apologize for the inconvenience, to stay up to date with the latest developments please click 'Subscribe'.
Posted Jun 28, 2025 - 18:37 CDT

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 7pm EST
Posted Jun 28, 2025 - 15:16 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Jun 28, 2025 - 13:07 CDT
This incident affected: Zentro Network (Zentro Internet).