Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 30, 2025 - 15:35 CDT
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 3:45 PM CDT.
Posted Sep 30, 2025 - 14:57 CDT
Update
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 2:00 PM CDT.
Posted Sep 30, 2025 - 10:50 CDT
Identified
We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 11:00 AM CDT.
Posted Sep 30, 2025 - 09:54 CDT
Investigating
We are currently investigating this issue.
Posted Sep 30, 2025 - 09:40 CDT
This incident affected: Zentro Network (Zentro Internet).