Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Oct 31, 2025 - 16:49 CDT
Update
Some customers may experience service disruptions. Our network team is working diligently to isolate and stabilize network connectivity for impacted customers. On-site technicians are continuing to troubleshoot. Our next update will be provided by 5:00 PM EST on 10/31. We appreciate your patience and understanding in the matter. To stay informed, please click 'Subscribe'.
Posted Oct 31, 2025 - 13:54 CDT
Update
Some customers may experience service disruptions. Our network team is working diligently to isolate and stabilize network connectivity for impacted customers. Our next update will be provided by 1:00 PM EST on 10/31. We appreciate your patience and understanding in the matter. To stay informed, please click 'Subscribe'.
Posted Oct 30, 2025 - 18:48 CDT
Identified
Some customers may experience service disruptions. Our technicians are on-site investigating impacted components. At this time, we are pending an estimated time of repair. Our next update will be provided by 6:00 PM EST. We appreciate your patience and understanding in the matter. To stay informed, please click 'Subscribe'.
Posted Oct 30, 2025 - 13:22 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Oct 29, 2025 - 16:51 CDT
This incident affected: Zentro Network (Zentro Internet).