183W - Chicago, IL - 1830 N. Winchester Ave.
Incident Report for Zentro Internet
Resolved
This incident was incident has been resolved and our team will continue to monitor the network to ensure stability
Posted Sep 07, 2024 - 16:43 CDT
Investigating
We are currently investigating and have dispatched techs out to the site
Posted Sep 07, 2024 - 12:59 CDT
This incident affected: Zentro Network (Zentro Internet).