235 West Van Buren Street, Chicago, IL

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Sep 27, 2025 - 12:21 CDT

Identified

We are currently investigating reports of service disruptions. Our technical teams are working diligently to isolate the root cause. An estimated time for resolution will be shared once the issue has been identified.
We sincerely apologize for the inconvenience and appreciate your patience during this time. Next update will be provided at 10:00 PM CST. To stay up to date with the latest developments, please click ‘Subscribe’.
Posted Sep 26, 2025 - 19:00 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Sep 26, 2025 - 16:51 CDT
This incident affected: Zentro Network (Zentro Internet).