415 W. Howard St., 605 Hinman Ave., 910 Judson Ave., 740 Main St., 2411 W. Fitch Ave. - Evanston IL
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jan 31, 2025 - 15:08 CST
Investigating
We are investigating reports of service interruptions at the location.
Posted Jan 31, 2025 - 12:12 CST