Chicago, IL - 405 E. Oakwood Blvd.
Incident Report for Zentro Internet
Resolved
issue resolved we'll continue to monitor
Posted Sep 12, 2024 - 12:13 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 12, 2024 - 07:57 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 12, 2024 - 07:54 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 11:00 AM.
Posted Sep 12, 2024 - 06:44 CDT
This incident affected: Zentro Network (Zentro Internet).