Georgia
Incident Report for Zentro
Resolved
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Nov 18, 2024 - 22:26 CST
Monitoring
Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Nov 18, 2024 - 21:22 CST
Identified
We have identified an issue impacting your service. Our team is moving quickly to resolve the issue. Estimated Time to Repair 2 AM EST.
Posted Nov 18, 2024 - 21:07 CST
Investigating
Locations in Georgia may be experiencing connectivity issues. Our Team is currently investigating.
Posted Nov 18, 2024 - 20:30 CST
This incident affected: Zentro Network (Zentro Internet).